廣告

2010-08-30

Ubuntu 如何安裝 PHP PECL 的擴充套件 ?

這是廣告


在 Ubuntu  如果只有安裝 php-pear 的話,還是會不能用 PECL 來安裝  PHP 的擴充套件,因為下載來的 PHP 擴充套件通常還是會需要再編譯過的,所以,一定要安裝 php-dev 的  PHP 開發套件才行,詳細操作步驟如下:

1.安裝需要的 PHP 套件
sudo apt-get install php-pear php5-dev

2.安裝 PECL 套件 (  以安裝 uploadprogress 擴充套件為例 )
sudo pecl install uploadprogress

3.修改 PHP.ini
在 php.ini 中新增 extension=uploadprogress.so ( Ubuntu 不需要指定路徑 )

4.重新啟動 Apache
sudo /etc/init.d/apache2 restart

問題還是沒解決嗎 ?? 這裡有更多的 Ubuntu 相關教學可以參考哩 ...


好文不藏私,請多分享囉!! ^^=


這是廣告

沒有留言 :

張貼留言

如果留言後,發現留言不見了,這通常是因為 Goolge 把它認為是垃圾留言了,請用信件通知阿舍調整 ( ayubiz@gmail.com )。謝謝 !