2013-11-22

Ubuntu 安裝 FBReader

阿舍用的 ePub 閱讀器,在 Android 手機上之是用 FBreader 這一套,而在 Ubuntu 上,則是因為要做轉檔的原故,所以,阿舍是安裝了 Calibre 這一套來用,Calibre 是一套功能不少又不錯用的電子書閱讀器,不過,雖然好用,阿舍總是覺得 Calibre 有點點笨重的感覺哩 ! 因此,才會想要回來安裝個比較輕量的 FBReader 來用哩 !

直接下載 Deb 安裝檔是比較快的方式哩 !
在 Ubuntu 上安裝 FBReader 是還滿簡單的事,因為是用像下面的這一行  apt-get 指令就可以安裝好的,不過,這個版本實在是有點久遠哩 !  是  FBReader 0.12.x 版的,而 FBReader for Linux 的版本已經到了 0.99.x 版了,所以,不在意的話,是可這樣安裝會比較省事的哩 !

sudo apt-get install fbreader

後來,阿舍有發現 FBReader 官網上有提供 Debian 用的儲存庫和安裝方式,阿舍參考了一下,然後,調成用下面的方式來安裝,結果,.... 就發現,兩個方法安裝出來的版本都是一樣的,也就是說,阿舍可以合理的推測,這個版本應該就是 Ubuntu 用的那個版本吧 !? ...

echo 'deb http://www.fbreader.org/desktop/debian stable main' | sudo tee -a  /etc/apt/sources.list

echo 'deb-src http://www.fbreader.org/desktop/debian stable main' | sudo tee -a  /etc/apt/sources.list

wget http://fbreader.org/files/debian/geometer.fbreader.org.asc

sudo apt-key add geometer.fbreader.org.asc

sudo apt-get update

sudo apt-get install fbreader

後來,阿舍又在 FBReader 的官網上找東西的時候,才又發現到,原來,FBReader 官網上是有提供 FBReader 最新版的 deb 安裝檔的,是阿舍自己沒注意看的哩 ! 所以,阿舍就到這裡來分別下載了 FBReader 安裝檔及其使用的 libunibreak 程式庫後 ( 有分 32 及64 位元版本 ),再用 dpkg 指令先裝 libuinbreak 程式庫,後安裝 FBReader,就可以順利安裝起來了哩 !

sudo dpkg -i libunibreak1_1.0-1_amd64.deb
sudo dpkg -i fbreader_0.99.4-1_amd64.deb

安裝完成後,要開啟來用的話,如果是用 apt-get 來安裝的話,因為 FBReader 的名稱會被改成 EBook-reader,而不是原來的 FBReader ,因此要用「E-Book reader」才能找的到,而如果是用 deb 檔安裝的話,則是會保持原來的 FBReader 名稱的哩 !

另外,阿舍試過了,不論用上面提到的那一種方式所安裝好的 FBReader,預設都是會使用簡體中文來顯示訊息的,如果想要改成正體中文的話,請把 /usr/share/FBReader/resources/zh.xml 和 /usr/share/FBReader/resources/zh.xml 這二個檔案拿來用簡轉繁軟體翻一下,再放回去就可以了,如果不想麻煩,就和阿舍一樣,用下面這二行指令來把中文譯檔移走,這樣,FBReader 就會英文界面了哩 !  ... ^^=

sudo mv /usr/share/FBReader/resources/zh.xml /usr/share/FBReader/resources/zh.xml.BAK
sudo mv /usr/share/zlibrary/resources/zh.xml /usr/share/zlibrary/resources/zh.xml.BAK


[+] Ubuntu 指令新手會用到的35個技法 - 這是以阿舍的使用經驗編寫出來的電子書,三天內應該就看的完,學的起來哩 ! 有空就參考一下囉 ! ... ^^=

關於阿舍

好文不藏私,請多分享囉!! ^^=



沒有留言 :

張貼留言

如果留言後,發現留言不見了,這通常是因為 Goolge 把它認為是垃圾留言了,請用信件通知阿舍調整 ( ayubiz@gmail.com )。謝謝 !