Ubuntu 安裝 Piwik 流量統計軟體 - 安裝準備

分享:
Piwik 是用 PHP5 開發的,所以,要先安裝 PHP5 ( 要 5.1.3 以上的版本 ),然後,Piwik 的資料是放在 MySQL,所以,也要安裝 MySQL ( 4.1 以上版本就可以了 ),另外,Piwik 會用到 PHP 的 GD 和 Wget 及 Unzip 等模組,所以,如果還沒有安裝過的話,就用下面的指令一次把它裝一裝。

sudo apt-get install wget unzip php5-gd

再來就是 PHP 的參數設定,不過,不是必須的,如果流量不大就不用調,這個是適合中、大型流量的網站用的,如果流量不太,就有需要時再調就好了。

sudo vi /etc/php5/apache2/php.ini 修改 memory_limit = 128M

最後再把 apache 重開一下就算完成準備工作了

sudo /etc/init.d/apache2 restart
分享:

沒有留言 :