如何解決 Your PHP MySQL library version 5.0.51a differs from your MySQL... 的問題 ?

這個是出現在 PHPMyAdmin 上的訊息,會出現這個的原因,是因為所安裝旳 PHP 版本不是最新的,但是 MySQL 是安裝 5.1 以上的版本,這樣才會出現這種訊息,要解決,不難,只要把 PHP 和 Apache 移掉,然後再重新安裝 PHP 5.3 及 Apache 2.2 以上的版本就可以解決了。

如果不想重裝 PHP 和 Apache也是可以的,那就要把 MySQL 移除,然後再去下載 MySQL 5.0.51a 的版本來安裝,讓 PHP 的 MySQL 程式庫版本和安裝的 MySQL 版本樣就可以了...
分享:

沒有留言 :